UltKit

MP3をOpusに変換

OpusはWebRTCの通話や多くのボイスメッセージで使われているコーデックで、MP3では音質が落ちる低いビットレートでも音楽や話し声をクリアに保ちます。ここでMP3を変換すれば、Web用やボット用、長時間の音声アーカイブ用に容量を減らせます。

音声変換

またはMP3, WAV, M4A … ファイルをここにドロップ ·

1ファイルあたり最大95 MB· 最大20ファイルまで· 30分後に削除

出力

ファイルは当社のサーバーで処理され、30分後に削除されます。

このツールの使い方

  1. 1

    MP3ファイルを追加

    MP3ファイルを最大20個まで選択してください。1ファイルあたり95 MBまで対応しており、曲、ポッドキャストのエピソード、講義、効果音などを変換できます。

  2. 2

    ビットレートを選択

    ビットレートは、Opus本来の設定であるVBR(可変)モードの96 kbpsです。音声には64 kbps、元のMP3が256 kbps以上の場合は128 kbpsを選んでください。

  3. 3

    Opusに変換

    Opusに変換を押して.opusファイルをダウンロードします。<audio>タグやボット、アーカイブにそのまま使えます。

MP3をOpusに変換するには、ファイルをアップロードしてOpusに変換を押します。デフォルトの96 kbps VBRなら、一般的な192 kbpsのMP3は約半分のサイズになり、音楽も音声も、ほとんどの人が元の音と聞き分けられない品質です。

MP3をOpusに変換する理由

Opusは、インターネット上のリアルタイムの音声や音楽向けに設計されたコーデックで、Skypeの音声コーデックSILKとXiph.Orgの音楽コーデックCELTを統合しています。エンコーダーが信号の変化に応じて2つの方式を切り替えるため、ポッドキャストでも通話でもポップスでも同じように高品質で、MP3なら音がこもり始めるようなビットレートでもクリアさを保ちます。

そのため、通信量やストレージにコストがかかる場面に向いています。たとえばWebアプリのBGM、チャットボットが送る音声クリップ、スマートフォンに保存する数百時間分の講義などです。DiscordやWhatsApp、すべてのWebRTCビデオ通話は、すでに内部でOpusを使っています。ファイルをプログラムではなく人に送る場合は、古いプレーヤーでも安心なMP3やMP3をAACに変換したAACのほうが無難です。

MP3とOpus:音声1時間あたりの容量

  • 320 kbpsのMP3144 MB
  • 192 kbpsのMP386 MB
  • 128 kbpsのOpus58 MB
  • 96 kbpsのOpus43 MB
  • 64 kbpsのOpus29 MB

IETFのドラフトからWeb標準の音声コーデックへ

  1. 2012

    RFC 6716

    IETFがOpusを標準規格として公開しています。ビットレートは6〜510 kbpsです。

  2. 2016

    RFC 7845

    Oggへのカプセル化が規定されており、ここでダウンロードする.opusファイルの形式を定義しています。

  3. 2016

    RFC 7874

    WebRTCでは、準拠するすべてのブラウザとアプリにOpus対応が必須とされています。

  4. 2017

    MP3の特許が失効

    MP3もロイヤリティフリーになったため、選ぶ基準はサイズと対応状況になりました。

MP3OpusOgg Vorbis
初公開199320122002
ビットレートの範囲8–320 kbps6–510 kbps約45–500 kbps
現在ロイヤリティフリーyesyesyes
Chrome、Firefox、Edgeで再生可能yesyesyes
WebRTCで必須noyesno
カーステレオや古いプレーヤーほぼすべてまれ一部

MP3とOpusの仕様

MP3

MP3オーディオ

MP3(MPEG-1 Audio Layer III)は、主にフラウンホーファー研究機構で開発され、1993年にMPEGが標準化した非可逆の音声形式です。耳につきにくい音を取り除き、128〜320 kbpsで音楽をCDの約10分の1のサイズに縮めます。特許はすべて失効しており、あらゆるスマートフォン、カーステレオ、ブラウザ、メディアプレーヤーが対応しています。低ビットレートでは音質の劣化が聞き取れ、再エンコードを重ねると劣化が蓄積します。

圧縮方式
非可逆
透過
–
アニメーション
–
登場時期
1993 · Fraunhofer IIS / MPEG
MP3 変換

OPUS

Opus音声

Opus は、2012年に IETF が標準化したオープンでロイヤリティフリーの非可逆音声コーデックです。低ビットレートの音声通話から全帯域の音楽まで適応でき、遅延も非常に小さいため、WhatsApp のボイスメッセージ、Discord、Zoom、WebRTC、YouTube で使われています。同じビットレートなら、一般に MP3 や AAC より高音質です。古いプレーヤー、カーステレオ、編集ソフトの多くは .opus ファイルを開けません。

圧縮方式
非可逆
透過
–
アニメーション
–
登場時期
2012 · IETF (Xiph.Org, Skype, Mozilla)
OPUS 変換

MP3は既存の音声の多くが採用している形式で、Opusは同じ音楽や音声をおよそ半分のビットレートで保てるため、Webアプリや音声ボット、容量を節約したいアーカイブで好まれています。変換すると、どこでも再生できる互換性と引き換えに、ファイルがはるかに小さくなります。

MP3からOpusへの変換:よくある質問

SafariやiPhoneで.opusファイルは再生できますか?

Appleのプラットフォームへの対応は他より遅れており、現在もシステムのバージョンやコンテナによって異なります。Chrome、Firefox、EdgeではOgg Opusをどこでも再生できます。すべてのデバイスで動作させたいWebページでは、2つ目の<source>要素にMP3またはAACのフォールバックを用意してください。

オーディオブックや講義の音声にはどのOpusビットレートが適していますか?

Opusが最も得意とするのは音声です。クリアな声ならモノラルで32〜48 kbpsあれば十分ですが、ここで選べる最小のビットレートは64 kbpsで、話し声には十分な余裕があります。話者が1人の場合はチャンネルをモノラルにすると、すべてのビットを1チャンネルに使えます。

OpusファイルがMP3とほとんど同じ容量になるのはなぜですか?

MP3自体に近いビットレートのままにしている可能性があります。Opusは低いビットレートで処理して初めて容量を節約できます。192 kbpsのMP3を96 kbpsで変換すると、サイズは約半分になります。元のMP3のビットレートを超えてOpusにエンコードしても意味はありません。

MP3からOpusへの変換で劣化がさらに重なりますか?

はい。非可逆から非可逆への変換なので、他の場合と同様に劣化はありますが、96 kbps以上ならほとんど聞き分けられません。また、Opusは内部サンプリングレートである48 kHzに音声をリサンプリングしますが、問題はありません。WAVやFLACの元データがある場合は、そちらからOpusにエンコードしてください。

OpusとOGGは同じものですか?

Oggはコンテナで、Opusはその中に格納できるコーデックの1つです。古いVorbisも同じコンテナに入れられます。.opusというファイルは、Opus音声を含むOggファイルです。ゲームエンジンやMODツールが.oggを求める場合は、たいていVorbisのことで、MP3をOGGに変換で作成できます。